blob: 884d4b3b8d87e51e1741c70eacf2af4b7f9a7704 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001SUMARY = "Corstone1000 platform Initramfs Image"
2DESCRIPTION = "This is the main Linux image which includes an initramfs kernel/rootfs bundle."
3
4LICENSE = "MIT"
5
6COMPATIBLE_MACHINE = "corstone1000"
7
8IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
9
10inherit core-image
11
12# By default all basic packages required for a bootable system are installed
13# by core-image . These packages are: packagegroup-core-boot and
14# packagegroup-base-extended
15
16inherit image-buildinfo
17
Brad Bishopbec4ebc2022-08-03 09:55:16 -040018#package management is not supported in corstone1000
19IMAGE_FEATURES:remove = "package-management"
20
21# all optee packages
22IMAGE_INSTALL += "optee-client"
23
Patrick Williams8dd68482022-10-04 07:57:18 -050024# external system linux userspace test application
25IMAGE_INSTALL += "corstone1000-external-sys-tests"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040026
Patrick Williams8dd68482022-10-04 07:57:18 -050027# TS PSA API tests commands for crypto, its, ps and iat
28IMAGE_INSTALL += "packagegroup-ts-tests-psa"