blob: d89915502890ead29d74c6e116581ad83c3f0cca [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Tracker miners and metadata extractors"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 intltool-native \
Andrew Geissler220dafd2023-10-04 10:18:08 -050010 libseccomp \
Andrew Geissler517393d2023-01-13 08:55:19 -060011 tracker \
12 zlib \
13"
14
15GNOMEBASEBUILDCLASS = "meson"
16
17inherit gnomebase gsettings gobject-introspection vala bash-completion features_check
18
Andrew Geissler220dafd2023-10-04 10:18:08 -050019SRC_URI:append = " \
20 file://0001-fix-reproducibility.patch \
21 file://0001-Set-header-file-to-a-fixed-path-instead-of-a-host-pa.patch \
22"
23SRC_URI[archive.sha256sum] = "c2ed9f6b0410195863b84c7b5467c5bc1255e96d658741192b5e92568a3bebd0"
Andrew Geissler517393d2023-01-13 08:55:19 -060024
25# gobject-introspection is mandatory and cannot be configured
26REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
27GIR_MESON_OPTION = ""
28
29PACKAGECONFIG ??= " \
30 ${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "ffmpeg", "", d)} \
31 gexiv2 \
32 gstreamer \
33 icu \
34 libexif \
35 libgsf \
36 jpeg \
37 pdf \
38 png \
39 tiff \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050040 raw \
Andrew Geissler517393d2023-01-13 08:55:19 -060041 xml \
42 ${@bb.utils.filter('DISTRO_FEATURES', 'seccomp', d)} \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050043 battery \
44 networkmanager \
Andrew Geissler517393d2023-01-13 08:55:19 -060045"
46
47PACKAGECONFIG[battery] = "-Dbattery_detection=upower,-Dbattery_detection=none,upower"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050048PACKAGECONFIG[cue] = "-Dcue=enabled,-Dcue=disabled,libcue"
49PACKAGECONFIG[ffmpeg] = "-Dgeneric_media_extractor=libav,,ffmpeg"
Andrew Geissler517393d2023-01-13 08:55:19 -060050PACKAGECONFIG[gexiv2] = ",,gexiv2"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050051PACKAGECONFIG[gstreamer] = "-Dgeneric_media_extractor=gstreamer,,gstreamer1.0 gstreamer1.0-plugins-base"
52PACKAGECONFIG[gupnp] = "-Dgstreamer_backend=gupnp,,gupnp-dlna"
Andrew Geissler517393d2023-01-13 08:55:19 -060053PACKAGECONFIG[gif] = "-Dgif=enabled,-Dgif=disabled,giflib"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050054PACKAGECONFIG[icu] = "-Dcharset_detection=icu,,icu"
55PACKAGECONFIG[iso] = "-Diso=enabled,-Diso=disabled,libosinfo"
Andrew Geissler517393d2023-01-13 08:55:19 -060056PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
57PACKAGECONFIG[libexif] = "-Dexif=enabled,-Dexif=disabled,libexif"
58PACKAGECONFIG[libgsf] = "-Dgsf=enabled,-Dgsf=disabled,libgsf"
59PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler"
60PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng"
61PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050062PACKAGECONFIG[raw] = "-Draw=enabled,-Draw=disabled,libraw"
Andrew Geissler517393d2023-01-13 08:55:19 -060063PACKAGECONFIG[xml] = "-Dxml=enabled,-Dxml=disabled,libxml2"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050064PACKAGECONFIG[networkmanager] = "-Dnetwork_manager=enabled,-Dnetwork_manager=disabled,networkmanager"
Andrew Geissler517393d2023-01-13 08:55:19 -060065
66# For security reasons it is strongly recommended to set add meta-security in
67# your layers and 'libseccomp' to PACKAGECONFIG".
68PACKAGECONFIG[seccomp] = "-Dseccomp=true,-Dseccomp=false,libseccomp"
69# not yet in meta-gnome
70PACKAGECONFIG[rss] = "-Dminer_rss=true,-Dminer_rss=false,libgrss"
71
72EXTRA_OEMESON += " \
73 -Dman=false \
74 -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \
75 -Dsystemd_user_services_dir=${systemd_user_unitdir} \
76"
77
78FILES:${PN} += " \
79 ${datadir}/dbus-1 \
80 ${datadir}/tracker3-miners \
81 ${libdir}/tracker-miners-3.0 \
82 ${systemd_user_unitdir} \
83"