Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Very simple session manager for X" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Simple session manager for X, that provides just the right boilerplate to create a session and launch the browser " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | HOMEPAGE = "http://www.yoctoproject.org" |
| 4 | BUGTRACKER = "http://bugzilla.pokylinux.org" |
| 5 | |
| 6 | PR = "r4" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://mini-x-session;endline=5;md5=b6430bffbcf05f9760e72938826b7487" |
| 10 | |
| 11 | SECTION = "x11" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RCONFLICTS:${PN} = "matchbox-common" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "file://mini-x-session" |
| 15 | S = "${WORKDIR}" |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN} = "sudo" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | inherit update-alternatives |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | ALTERNATIVE:${PN} = "x-session-manager" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/mini-x-session" |
| 23 | ALTERNATIVE_PRIORITY = "50" |
| 24 | |
| 25 | do_install() { |
| 26 | install -d ${D}/${bindir} |
| 27 | install -m 0755 ${S}/mini-x-session ${D}/${bindir} |
| 28 | } |