blob: 7ca67e44fb60c8eb125fe091cb7d26e72886f0b7 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD-3-Clause"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060017SRC_URI[sha256sum] = "64ac4614db292ae8c5aa26de0295bf1623dbb3985054cb656c55e67431def17c"
Patrick Williams92b42cb2022-09-03 06:53:57 -050018
19UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
20
Patrick Williams520786c2023-06-25 16:20:36 -050021SRC_URI += " \
22 file://CVE-2023-1999.patch \
23"
24
Patrick Williams92b42cb2022-09-03 06:53:57 -050025EXTRA_OECONF = " \
26 --disable-wic \
27 --enable-libwebpmux \
28 --enable-libwebpdemux \
29 --enable-threading \
30"
31
32# Do not trust configure to determine if neon is available.
33#
34EXTRA_OECONF_ARM = " \
35 ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
36"
37EXTRA_OECONF:append:arm = " ${EXTRA_OECONF_ARM}"
38EXTRA_OECONF:append:armeb = " ${EXTRA_OECONF_ARM}"
39
40inherit autotools lib_package
41
42PACKAGECONFIG ??= ""
43
44# libwebpdecoder is a subset of libwebp, don't build it unless requested
45PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
46
47# Apply for examples programs: cwebp and dwebp
48PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
49PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
50PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
51PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
52
53# Apply only for example program vwebp
54PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
55
56PACKAGES =+ "${PN}-gif2webp"
57
58DESCRIPTION:${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
59FILES:${PN}-gif2webp = "${bindir}/gif2webp"
Patrick Williamse760df82023-05-26 11:10:49 -050060
61BBCLASSEXTEND += "native nativesdk"