blob: 8ab0febaad4059f85813386cdd49a6fa7d35ab6d [file] [log] [blame]
Lancelot Kaoc2c04b02021-02-22 22:55:06 -06001SUMMARY = "foxconn OEM IPMI commands"
2DESCRIPTION = "foxconn OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7S = "${WORKDIR}/git"
8
9DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
10
Peter Foleyc1416102022-01-25 01:09:11 +000011inherit cmake pkgconfig obmc-phosphor-ipmiprovider-symlink
Lancelot Kaoc2c04b02021-02-22 22:55:06 -060012
13EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
14
15LIBRARY_NAMES = "libfiioemcmds.so"
16
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/foxconn-ipmi-oem.git;branch=master;protocol=https"
Andrew Geissler9ee881f2022-02-08 00:50:09 +000018SRCREV = "9d6c4010b58049070afcb39ef4c2a965633e2e9c"
Lancelot Kaoc2c04b02021-02-22 22:55:06 -060019
20HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
21NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050023FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
25FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
26FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"