Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Python interface to libarchive" |
| 2 | DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \ |
| 3 | dynamically load and access the C library." |
| 4 | HOMEPAGE = "https://github.com/Changaco/python-libarchive-c" |
| 5 | LICENSE = "CC0-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc" |
| 7 | |
| 8 | PYPI_PACKAGE = "libarchive-c" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "d673f56673d87ec740d1a328fa205cafad1d60f5daca4685594deb039d32b159" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | libarchive \ |
| 16 | ${PYTHON_PN}-ctypes \ |
| 17 | ${PYTHON_PN}-mmap \ |
| 18 | ${PYTHON_PN}-logging \ |
| 19 | " |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |