blob: e34dba123ce6366e64c40346425c6227ca7b0125 [file] [log] [blame]
Joel Stanley7259c7d2019-11-04 23:43:51 +10301SUMMARY = "eCMD"
2DESCRIPTION = "eCMD is a hardware access API for IBM Systems"
3LICENSE= "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
5
6SRC_URI = "git://github.com/open-power/eCMD.git"
Joel Stanleyac6d51c2020-01-03 13:53:18 +11007SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07"
Joel Stanley7259c7d2019-11-04 23:43:51 +10308DEPENDS += "python-native zlib"
9
Joel Stanley5f2105b2019-11-05 11:25:16 +103010SRC_URI += "file://croserver.service"
11
Joel Stanley7259c7d2019-11-04 23:43:51 +103012S = "${WORKDIR}/git"
13
Joel Stanley7259c7d2019-11-04 23:43:51 +103014do_configure() {
Joel Stanleyac6d51c2020-01-03 13:53:18 +110015 LD="${CXX}" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
Joel Stanley7259c7d2019-11-04 23:43:51 +103016}
17
18do_compile() {
19 cd ${S}/dllNetwork/server
20 oe_runmake
21}
22
23do_install() {
24 install -d ${D}${bindir}
25 install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
Joel Stanley5f2105b2019-11-05 11:25:16 +103026
27 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
Joel Stanley7259c7d2019-11-04 23:43:51 +103029}
Joel Stanley5f2105b2019-11-05 11:25:16 +103030
31FILES_${PN} += "${systemd_system_unitdir}/croserver.service"