blob: 51a854d44a4ec5aced6b2cc9b3351412ba26be0f [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3HOMEPAGE = "https://github.com/lz4/lz4"
4
5LICENSE = "BSD-2-Clause | GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=5cd5f851b52ec832b10eedb3f01f885a \
7 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://LICENSE;md5=c5cc3cd6f9274b4d32988096df9c3ec3 \
9 "
10
11PE = "1"
12
13SRCREV = "5ff839680134437dbf4678f3d0c7b371d84f4964"
14
Andrew Geissler028142b2023-05-05 11:29:21 -050015SRC_URI = "git://github.com/lz4/lz4.git;branch=release;protocol=https \
16 file://run-ptest \
17 "
Patrick Williams92b42cb2022-09-03 06:53:57 -050018UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
19
20S = "${WORKDIR}/git"
21
Andrew Geissler028142b2023-05-05 11:29:21 -050022inherit ptest
23
Andrew Geissler8f840682023-07-21 09:09:43 -050024CVE_STATUS[CVE-2014-4715] = "fixed-version: Fixed in r118, which is larger than the current version."
Patrick Williams92b42cb2022-09-03 06:53:57 -050025
26EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' CFLAGS='${CFLAGS}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir} BUILD_STATIC=no"
27
28do_install() {
29 oe_runmake install
30}
31
32BBCLASSEXTEND = "native nativesdk"
Andrew Geissler028142b2023-05-05 11:29:21 -050033
34RDEPENDS:${PN}-ptest += "bash"
35
36do_compile_ptest() {
37 oe_runmake -C ${B}/tests/
38}
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/tests/
42 install --mode=755 ${B}/tests/frametest ${D}${PTEST_PATH}/tests/
43 sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/run-ptest
44
45}
46