blob: 7e80354e4e74dc1b7d769cccc37bf79086594b9e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN} = "${PN}-client bash"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15inherit useradd
16
17USERADD_PACKAGES = "${PN}-client"
18USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
19 --shell /bin/false --user-group rpcuser"
20
21SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
22 file://nfsserver \
23 file://nfscommon \
24 file://nfs-utils.conf \
25 file://nfs-server.service \
26 file://nfs-mountd.service \
27 file://nfs-statd.service \
28 file://proc-fs-nfsd.mount \
29 file://nfs-utils-debianize-start-statd.patch \
30 file://bugfix-adjust-statd-service-name.patch \
Brad Bishop19323692019-04-05 15:28:33 -040031 file://0001-cacheio-use-intmax_t-for-formatted-IO.patch \
Brad Bishop19323692019-04-05 15:28:33 -040032 file://clang-format-string.patch \
Brad Bishop19323692019-04-05 15:28:33 -040033 file://0001-Makefile.am-fix-undefined-function-for-libnsm.a.patch \
34 file://0001-Don-t-build-tools-with-CC_FOR_BUILD.patch \
Brad Bishopa34c0302019-09-23 22:34:48 -040035 file://0001-Fix-include-order-between-config.h-and-stat.h.patch \
Brad Bishop19323692019-04-05 15:28:33 -040036"
37SRC_URI_append_libc-glibc = " file://0001-configure.ac-Do-not-fatalize-Wmissing-prototypes.patch"
38SRC_URI_append_libc-musl = " file://nfs-utils-musl-res_querydomain.patch"
39
Brad Bishop79641f22019-09-10 07:20:22 -040040SRC_URI[md5sum] = "161efe469ec1b06f1c750bd87f8ba6dd"
41SRC_URI[sha256sum] = "85274ada94479b1beba9f8eeffd19f477c53a6710b9998d1192c807854087736"
Brad Bishop19323692019-04-05 15:28:33 -040042
43# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
44# pull in the remainder of the dependencies.
45
46INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
47INITSCRIPT_NAME = "nfsserver"
48INITSCRIPT_PARAMS = "defaults"
49INITSCRIPT_NAME_${PN}-client = "nfscommon"
50INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
51
52inherit autotools-brokensep update-rc.d systemd pkgconfig
53
54SYSTEMD_PACKAGES = "${PN} ${PN}-client"
55SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
56SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
57
58# --enable-uuid is need for cross-compiling
59EXTRA_OECONF = "--with-statduser=rpcuser \
60 --enable-mountconfig \
61 --enable-libmount-mount \
62 --enable-uuid \
63 --disable-gss \
64 --disable-nfsdcltrack \
65 --with-statdpath=/var/lib/nfs/statd \
66 "
67
68CFLAGS += "-Wno-error=format-overflow"
69
70PACKAGECONFIG ??= "tcp-wrappers \
71 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
72"
73PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
74PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
75PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
76# libdevmapper is available in meta-oe
77PACKAGECONFIG[nfsv41] = "--enable-nfsv41,--disable-nfsv41,libdevmapper"
78# keyutils is available in meta-security
79PACKAGECONFIG[nfsv4] = "--enable-nfsv4,--disable-nfsv4,keyutils"
80
81PACKAGES =+ "${PN}-client ${PN}-mount ${PN}-stats"
82
83CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
84 ${localstatedir}/lib/nfs/rmtab \
85 ${localstatedir}/lib/nfs/xtab \
86 ${localstatedir}/lib/nfs/statd/state \
87 ${sysconfdir}/nfsmount.conf"
88
89FILES_${PN}-client = "${sbindir}/*statd \
90 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
91 ${sbindir}/showmount ${sbindir}/nfsstat \
92 ${localstatedir}/lib/nfs \
93 ${sysconfdir}/nfs-utils.conf \
94 ${sysconfdir}/nfsmount.conf \
95 ${sysconfdir}/init.d/nfscommon \
96 ${systemd_unitdir}/system/nfs-statd.service"
97RDEPENDS_${PN}-client = "${PN}-mount rpcbind"
98
99FILES_${PN}-mount = "${base_sbindir}/*mount.nfs*"
100
101FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
102RDEPENDS_${PN}-stats = "python3-core"
103
104FILES_${PN} += "${systemd_unitdir}"
105
106do_configure_prepend() {
107 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
108 ${S}/utils/mount/Makefile.am
Brad Bishop19323692019-04-05 15:28:33 -0400109}
110
111# Make clean needed because the package comes with
112# precompiled 64-bit objects that break the build
113do_compile_prepend() {
114 make clean
115}
116
Brad Bishopc68388fc2019-08-26 01:33:31 -0400117# Works on systemd only
118HIGH_RLIMIT_NOFILE ??= "4096"
119
Brad Bishop19323692019-04-05 15:28:33 -0400120do_install_append () {
121 install -d ${D}${sysconfdir}/init.d
122 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
123 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
124
125 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
126 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
127
128 install -d ${D}${systemd_unitdir}/system
129 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
130 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
131 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
132 sed -i -e 's,@SBINDIR@,${sbindir},g' \
133 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
Brad Bishopc68388fc2019-08-26 01:33:31 -0400134 -e 's,@HIGH_RLIMIT_NOFILE@,${HIGH_RLIMIT_NOFILE},g' \
Brad Bishop19323692019-04-05 15:28:33 -0400135 ${D}${systemd_unitdir}/system/*.service
136 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
137 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
138 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
139 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
140 fi
141
142 # kernel code as of 3.8 hard-codes this path as a default
143 install -d ${D}/var/lib/nfs/v4recovery
144
145 # chown the directories and files
146 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
147 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
148
149 # Make python tools use python 3
150 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${sbindir}/mountstats ${D}${sbindir}/nfsiostat
151
152}