blob: 38bc8d2c338ddebbae194c617d2aadbb7b80afe8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Library to handle input devices in Wayland compositors"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63"
7
8DEPENDS = "libevdev udev mtdev"
9
10SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz"
Brad Bishopa34c0302019-09-23 22:34:48 -040011SRC_URI[md5sum] = "da29a704dc6f7ea2d5aac754db046340"
12SRC_URI[sha256sum] = "e333a3242835c019ca37d2cef8b51a87d3138eb47444119c0153dc7a8656ee70"
Brad Bishopc342db32019-05-15 21:57:59 -040013
14UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
15
16inherit meson pkgconfig lib_package
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
20PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
21
22UDEVDIR = "`pkg-config --variable=udevdir udev`"
23
Brad Bishopa34c0302019-09-23 22:34:48 -040024EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
25 -Ddocumentation=false \
26 -Dtests=false \
27 -Dzshcompletiondir=no"
Brad Bishopc342db32019-05-15 21:57:59 -040028
29# package name changed in 1.8.1 upgrade: make sure package upgrades work
30RPROVIDES_${PN} = "libinput"
31RREPLACES_${PN} = "libinput"
32RCONFLICTS_${PN} = "libinput"