blob: a4d1ae43d93aaa62ce46174fad061071d0af16c7 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
Brad Bishop08902b02019-08-20 09:16:51 -040017SRC_URI[md5sum] = "906ad85daaaa2eac97c8aa2dec9e8b77"
18SRC_URI[sha256sum] = "e20a07865c8697bba00aebccc6f54912d6bc333bb4d604e6b07491c1a226b34f"
Brad Bishop19323692019-04-05 15:28:33 -040019
20UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
21
22EXTRA_OECONF = " \
23 --disable-wic \
24 --enable-libwebpmux \
25 --enable-libwebpdemux \
26 --enable-threading \
27"
Brad Bishopa34c0302019-09-23 22:34:48 -040028
Brad Bishop19323692019-04-05 15:28:33 -040029# Do not trust configure to determine if neon is available.
30#
Brad Bishopa34c0302019-09-23 22:34:48 -040031EXTRA_OECONF_ARM = " \
Brad Bishop19323692019-04-05 15:28:33 -040032 ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
33"
Brad Bishopa34c0302019-09-23 22:34:48 -040034EXTRA_OECONF_append_arm = " ${EXTRA_OECONF_ARM}"
35EXTRA_OECONF_append_armeb = " ${EXTRA_OECONF_ARM}"
Brad Bishop19323692019-04-05 15:28:33 -040036
37inherit autotools lib_package
38
39PACKAGECONFIG ??= ""
40
41# libwebpdecoder is a subset of libwebp, don't build it unless requested
42PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
43
44# Apply for examples programs: cwebp and dwebp
45PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
46PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
47PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
48PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
49
50# Apply only for example program vwebp
51PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
52
53PACKAGES =+ "${PN}-gif2webp"
54
55DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
56FILES_${PN}-gif2webp = "${bindir}/gif2webp"