blob: 032f3655e9a283436ae0d301087909f305f43d14 [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2HOMEPAGE = "https://github.com/libical/libical"
3BUGTRACKER = "https://github.com/libical/libical/issues"
4LICENSE = "LGPLv2.1 | MPL-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
6 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
7 file://LICENSE.MPL2.txt;md5=9741c346eef56131163e13b9db1241b3"
8SECTION = "libs"
9
10SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
11
Brad Bishopa34c0302019-09-23 22:34:48 -040012SRC_URI[md5sum] = "463a59244c6767b8e67b29379405e297"
13SRC_URI[sha256sum] = "5c8a21c2b732ece4a33e5c862970b4f35a8548bbcda50de5695f6fc211ac4d97"
Brad Bishop08902b02019-08-20 09:16:51 -040014UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
15
16inherit cmake pkgconfig
17
18PACKAGECONFIG ??= "icu"
19PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
20# ICU is used for RSCALE (RFC7529) support
21PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
22
23# No need to use perl-native, the host perl is sufficient.
24EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
25
26# The glib library can't be cross-compiled, disable for now.
27# https://github.com/libical/libical/issues/394
28EXTRA_OECMAKE += "-DICAL_GLIB=false"
29
30do_install_append_class-target () {
31 # Remove build host references
32 sed -i \
33 -e 's,${STAGING_LIBDIR},${libdir},g' \
34 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake
35}