blob: 17f1fc8265ac2e34a96cc1287161ff8491c0a7d5 [file] [log] [blame]
Duke Dudddc5012019-05-29 09:19:24 +08001SUMMARY = "OpenBMC Quanta Detect Fan Fail Service"
2DESCRIPTION = "OpenBMC Quanta Detect Fan Fail Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
Brad Bishop07d2b9d2019-09-13 13:04:22 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Duke Dudddc5012019-05-29 09:19:24 +08006
7inherit systemd
8
9DEPENDS += "systemd"
Willy Tua38b7cc2021-08-10 15:33:55 -070010RDEPENDS:${PN} += "bash"
Duke Dudddc5012019-05-29 09:19:24 +080011
Willy Tua38b7cc2021-08-10 15:33:55 -070012FILESEXTRAPATHS:append:gsj := "${THISDIR}/files:"
13SRC_URI:append:gsj = " file://detect-fan-fail.sh \
Duke Dudddc5012019-05-29 09:19:24 +080014 file://detect-fan-fail.service \
15 "
16
Willy Tua38b7cc2021-08-10 15:33:55 -070017do_install:append:gsj() {
Duke Dudddc5012019-05-29 09:19:24 +080018 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/detect-fan-fail.sh ${D}${bindir}/
20
21 install -d ${D}${systemd_unitdir}/system/
22 install -m 0644 ${WORKDIR}/detect-fan-fail.service ${D}${systemd_unitdir}/system
23}
24
25SYSTEMD_PACKAGES = "${PN}"
Willy Tua38b7cc2021-08-10 15:33:55 -070026SYSTEMD_SERVICE:${PN} = "detect-fan-fail.service"