blob: e6132faa7d7f193ee7da35b6f17a3c4aa66e2d1d [file] [log] [blame]
Brad Bishop36098402015-09-17 16:39:49 -04001# Common code for applications providing a D-Bus service.
2
3# Class users should define DBUS_SERVICES prior to including.
4
Brad Bishopef552f62015-09-25 10:23:09 -04005RDEPENDS_${PN} += "dbus-perms"
6
Brad Bishop36098402015-09-17 16:39:49 -04007python() {
Brad Bishop62ae0bf2015-09-21 17:07:52 -04008 services = d.getVar('DBUS_SERVICES', True)
9 if services:
10 uris = " ".join( [ 'file://' + s + '.conf' for s in services.split() ] )
Brad Bishop1cd45602015-09-21 21:56:48 -040011 d.appendVar('SRC_URI', ' ' + uris + ' ')
Brad Bishop36098402015-09-17 16:39:49 -040012}
13
14do_install_append() {
15 # install the service configuration files
16 install -d ${D}${sysconfdir}/dbus-1/system.d
17 for s in ${DBUS_SERVICES}; do
18 install ${WORKDIR}/$s.conf ${D}${sysconfdir}/dbus-1/system.d/$s.conf
19 done
20}