blob: 378be1a8eb6d31618418ae4f4b7ad2416894f720 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "[Boost::ext].SML (State Machine Language)"
2DESCRIPTION = "Your scalable C++14 one header only State Machine Library with no dependencies"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003HOMEPAGE = "https://github.com/boost-ext/sml"
4BUGTRACKER = "https://github.com/boost-ext/sml/issues"
5SECTION = "libs"
6LICENSE = "BSL-1.0"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=e4224ccaecb14d942c71d31bef20d78c"
8
9DEPENDS += "boost qemu-native"
10
Andrew Geissler220dafd2023-10-04 10:18:08 -050011PV = "1.1.9"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012
13SRC_URI = "git://github.com/boost-ext/sml.git;protocol=https;branch=master"
Andrew Geissler220dafd2023-10-04 10:18:08 -050014SRCREV = "751b6f10b73c086e0e8850a7ef5b5aea2136831b"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20# Building benchmarks takes a lot of time and requires additional headers (euml2.hpp)
Patrick Williams03907ee2022-05-01 06:28:52 -050021# Building examples fail with gcc-12
22EXTRA_OECMAKE:append = " -DSML_BUILD_BENCHMARKS:bool=OFF -DSML_BUILD_EXAMPLES=OFF"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023
24# [boost::ext].XML is a header only C++ library, so the main package will be empty.
25ALLOW_EMPTY:${PN} = "1"
26
27BBCLASSEXTEND = "nativesdk"