blob: 08766b31242d1028376ef985c08e6732f49206f0 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-Correctly-install-the-shared-library.patch \
Brad Bishopa5c52ff2018-11-23 10:55:50 +130010 file://0001-Fix-setup-of-logging-log-domains-RhBug-1645897.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011 "
12
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013PV = "0.11.1+git${SRCPV}"
14SRCREV = "434a40babdde57ab405e9a1085a30e9575ea0c92"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16S = "${WORKDIR}/git"
17
18DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
19DEPENDS_append_class-native = " file-replacement-native"
20
21inherit cmake pkgconfig bash-completion distutils3-base
22
23EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
24
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025BBCLASSEXTEND = "native nativesdk"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026
27# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
28do_install_append_class-native() {
29 create_wrapper ${D}/${bindir}/createrepo_c \
30 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
31}
32
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033do_install_append_class-nativesdk() {
34 create_wrapper ${D}/${bindir}/createrepo_c \
35 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
36 rm -rf ${D}/etc
37}