blob: 1a1ee97dc2cfc050b26a7d29d3ad0f0e987e9598 [file] [log] [blame]
Alexander Filippov126f6672018-11-28 11:32:04 +03001SUMMARY = "Init BMC MAC address"
2DESCRIPTION = "Setup BMC MAC address read from VPD"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
6
7inherit allarch systemd
8
9RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
10
11SYSTEMD_SERVICE_${PN} = "first-boot-set-mac@.service"
12
Brad Bishop558caea2019-06-21 09:32:36 -040013SRC_URI = "file://${BPN}.sh file://${BPN}@.service"
Alexander Filippov126f6672018-11-28 11:32:04 +030014
15S = "${WORKDIR}"
16do_install() {
17 install -d ${D}${bindir} ${D}${systemd_system_unitdir}
Brad Bishop558caea2019-06-21 09:32:36 -040018 install ${BPN}.sh ${D}${bindir}/
19 install -m 644 ${BPN}@.service ${D}${systemd_system_unitdir}/
Alexander Filippov126f6672018-11-28 11:32:04 +030020}