blob: 843e704620559dc735cb85e2efebdb91dcc4cb2b [file] [log] [blame]
Benjamin Fairfbf258a2019-10-21 18:45:41 -07001SUMMARY = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
2DESCRIPTION = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
3HOMEPAGE = "https://github.com/Nuvoton-Israel/igps"
Patrick Williamsd541ec52022-04-30 07:41:26 -05004LICENSE = "GPL-2.0-only"
Benjamin Fairfbf258a2019-10-21 18:45:41 -07005LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = " \
Patrick Williamsbb99d222022-01-24 15:55:09 -06008 git://github.com/Nuvoton-Israel/igps;branch=master;protocol=https \
Benjamin Fairfbf258a2019-10-21 18:45:41 -07009 file://0001-Adjust-paths-for-use-with-Bitbake.patch \
10"
Tim Leea80b1192023-08-01 15:57:32 +080011# tag IGPS_02.01.18
12SRCREV = "e0fc2ba58d561220a957bc06aefe1ac7f6e96126"
Benjamin Fairfbf258a2019-10-21 18:45:41 -070013
14S = "${WORKDIR}/git"
15
16DEST = "${D}${datadir}/${BPN}"
17
18do_install() {
19 install -d ${DEST}
20 install ImageGeneration/references/BootBlockAndHeader_${IGPS_MACHINE}.xml ${DEST}
21 install ImageGeneration/references/UbootHeader_${IGPS_MACHINE}.xml ${DEST}
22 install ImageGeneration/inputs/mergedBootBlockAndUboot.xml ${DEST}
23}
24
25inherit native