Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject" |
| 2 | DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\ |
| 3 | data structures, using a DOM-like API. JSON-GLib also offers GObject \ |
| 4 | integration, providing the ability to serialize and deserialize GObject \ |
| 5 | instances to and from JSON data types." |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 6 | HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | LICENSE = "LGPLv2.1" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
| 12 | DEPENDS = "glib-2.0" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages |
| 16 | |
| 17 | SRC_URI += "file://run-ptest" |
| 18 | SRC_URI[archive.md5sum] = "4d4bb9837f6d31e32d0ce658ae135f68" |
| 19 | SRC_URI[archive.sha256sum] = "720c5f4379513dc11fd97dc75336eb0c0d3338c53128044d9fabec4374f4bc47" |
| 20 | |
| 21 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native" |
| 22 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | do_install_append() { |
| 24 | if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then |
| 25 | rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir} |
| 26 | fi |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |
| 30 | |
| 31 | # Currently it's not possible to disable gettext in Meson, so we need to force |
| 32 | # this back on. |
| 33 | USE_NLS_class-native = "yes" |