blob: 2f6fb59d21ad7c2265d70494404af05240dd4024 [file] [log] [blame]
Patrick Venture6dd5cc92018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
Patrick Venturea9f19bd2019-03-07 10:51:53 -080016DEPENDS += "ipmi-blob-tool"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080017
18S = "${WORKDIR}/git"
19SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geisslerba2cdb72019-03-07 15:52:07 +000020SRCREV = "6bc04f9491d8ab6a68123fccfed99d30dd9e0d3c"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080021
22FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
24FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
25
26BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"