Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Project parser generator (yacc replacement)" |
| 2 | DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \ |
| 3 | an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \ |
| 4 | grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \ |
| 5 | little trouble." |
| 6 | HOMEPAGE = "http://www.gnu.org/software/bison/" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 9 | SECTION = "devel" |
| 10 | DEPENDS = "bison-native flex-native" |
| 11 | |
| 12 | SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
| 14 | file://dont-depend-on-help2man.patch.patch \ |
| 15 | file://0001-src-local.mk-fix-parallel-issue.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 16 | file://add-with-bisonlocaledir.patch \ |
Khem Raj | 2429c7e | 2018-08-06 15:57:04 -0700 | [diff] [blame] | 17 | file://gnulib.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | # No point in hardcoding path to m4, just use PATH |
| 21 | EXTRA_OECONF += "M4=m4" |
| 22 | |
| 23 | SRC_URI[md5sum] = "c342201de104cc9ce0a21e0ad10d4021" |
| 24 | SRC_URI[sha256sum] = "a72428c7917bdf9fa93cb8181c971b6e22834125848cf1d03ce10b1bb0716fe1" |
| 25 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | inherit autotools gettext texinfo |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | |
| 28 | # The automatic m4 path detection gets confused, so force the right value |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | acpaths = "-I ${S}/m4" |
| 30 | |
| 31 | do_compile_prepend() { |
| 32 | for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done |
| 33 | } |
| 34 | |
| 35 | do_install_append_class-native() { |
| 36 | create_wrapper ${D}/${bindir}/bison \ |
| 37 | BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison |
| 38 | } |
| 39 | BBCLASSEXTEND = "native nativesdk" |