Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 4 | SUMMARY = "Glibc hierarchical argument parsing standalone library" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 5 | HOMEPAGE = "http://www.lysator.liu.se/~nisse/misc/" |
| 6 | LICENSE = "LGPL-2.1" |
| 7 | LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=008b7e53dea6f9e1d9fdef0d9cf3184a" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | SRC_URI = "http://www.lysator.liu.se/~nisse/misc/argp-standalone-${PV}.tar.gz \ |
| 11 | file://0001-throw-in-funcdef.patch \ |
| 12 | file://0002-isprint.patch \ |
| 13 | file://out_of_tree_build.patch \ |
| 14 | " |
| 15 | SRC_URI[md5sum] = "720704bac078d067111b32444e24ba69" |
| 16 | SRC_URI[sha256sum] = "dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be" |
| 17 | |
| 18 | inherit autotools |
| 19 | |
| 20 | CFLAGS += "-fPIC -U__OPTIMIZE__" |
| 21 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | RDEPENDS_${PN}-dev = "" |
| 23 | RDEPENDS_${PN}-staticdev = "" |
| 24 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 25 | do_install() { |
| 26 | install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a |
| 27 | install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h |
| 28 | } |
| 29 | # |
| 30 | # We will skip parsing for non-musl systems |
| 31 | # |
| 32 | COMPATIBLE_HOST = ".*-musl.*" |