blob: 4f1498546992352c38c45f6884ef88311ba4d6c3 [file] [log] [blame]
Patrick Williams864cc432023-02-09 14:54:44 -06001DESCRIPTION = "a graphical user interface that allows the user to change print settings"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/OpenPrinting/system-config-printer.git;protocol=https;branch=master"
6
7SRCREV = "895d3dec50c93bfd4f142bac9bfcc13051bf84cb"
8S = "${WORKDIR}/git"
9
10inherit autotools gettext pkgconfig python3native features_check
11
Patrick Williamsb542dec2023-06-09 01:26:37 -050012REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
Patrick Williams864cc432023-02-09 14:54:44 -060013
Patrick Williamse760df82023-05-26 11:10:49 -050014DEPENDS = "cups glib-2.0 libusb xmlto-native desktop-file-utils-native autoconf-archive-native"
Patrick Williams864cc432023-02-09 14:54:44 -060015
16PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
Patrick Williamse760df82023-05-26 11:10:49 -050017PACKAGECONFIG[systemd] = ",--without-systemdsystemunitdir,systemd"
Patrick Williams864cc432023-02-09 14:54:44 -060018
19do_configure:prepend() {
20 # This file is not provided if fetching from git but required for configure
21 touch ${S}/ChangeLog
22}
23
Patrick Williamse760df82023-05-26 11:10:49 -050024do_install:append() {
25 for f in __init__.cpython-311.pyc cupshelpers.cpython-311.pyc \
26 config.cpython-311.pyc ppds.cpython-311.pyc \
27 installdriver.cpython-311.pyc openprinting.cpython-311.pyc \
28 xmldriverprefs.cpython-311.pyc; do
29 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/cupshelpers/__pycache__/$f
30 done
31}
32
Patrick Williams864cc432023-02-09 14:54:44 -060033FILES:${PN} += "${libdir} ${datadir}"
34
35RDEPENDS:${PN} = " \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060036 cups \
Patrick Williams864cc432023-02-09 14:54:44 -060037 dbus-x11 \
38 gtk+3 \
39 libnotify \
40 python3-core \
41 python3-dbus \
42 python3-firewall \
43 python3-pycups \
44 python3-pycurl \
45 python3-pygobject \
46"