blob: 46fa81866bc7b0471ba77af5f98d015d15db1c7f [file] [log] [blame]
Andrew Geissler32b11992021-03-31 13:37:05 -05001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A C library that may be linked into a C/C++ program to produce symbolic backtraces"
5HOMEPAGE = "https://github.com/ianlancetaylor/libbacktrace"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=24b5b3feec63c4be0975e1fea5100440"
8
9DEPENDS += "libunwind"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master"
Andrew Geissler32b11992021-03-31 13:37:05 -050012
13PV = "1.0+git${SRCPV}"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060014SRCREV = "9ae4f4ae4481b1e69d38ed810980d33103544613"
Andrew Geissler32b11992021-03-31 13:37:05 -050015
16S = "${WORKDIR}/git"
17
18inherit autotools
19
Patrick Williamsac13d5f2023-11-24 18:59:46 -060020EXTRA_OECONF += "--with-system-libunwind --enable-shared --disable-static"
Andrew Geissler32b11992021-03-31 13:37:05 -050021
22do_configure() {
23 oe_runconf
24}
25
Patrick Williamsac13d5f2023-11-24 18:59:46 -060026# libunwind does not support RISCV32 yet
Patrick Williams213cb262021-08-07 19:21:33 -050027COMPATIBLE_HOST:riscv32 = "null"