blob: ffe2f366ea94559039c8e45acccfeabe4ac7361e [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
2DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
3PR = "r1"
Patrick Venturec233b002018-10-09 20:20:36 -07004PV = "1.0+git${SRCPV}"
Brad Bishop5f9be072016-06-27 14:53:52 -04005
6inherit skeleton-gdbus
Brad Bishop1d525fa2016-08-17 20:27:37 -04007inherit obmc-phosphor-dbus-service
Brad Bishop92673622018-01-26 21:30:17 -05008inherit pkgconfig
Brad Bishop5f9be072016-06-27 14:53:52 -04009
Sergey Solominaac4adf2016-11-28 15:03:24 -060010PROVIDES += "virtual/obmc-host-ctl"
Patrick Williams12fc9392021-08-06 09:16:53 -050011RPROVIDES:${PN} += "virtual-obmc-host-ctl"
Sergey Solominaac4adf2016-11-28 15:03:24 -060012
Brad Bishop5f9be072016-06-27 14:53:52 -040013SKELETON_DIR = "op-hostctl"
Brad Bishop1d525fa2016-08-17 20:27:37 -040014
15FMT = "org.openbmc.control.Host@{0}.service"
Patrick Williams12fc9392021-08-06 09:16:53 -050016DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
17SYSTEMD_SERVICE:${PN} = " \
Andrew Geissler238f3a72017-03-23 12:48:06 -050018 op-start-host@.service \
Andrew Geissler238f3a72017-03-23 12:48:06 -050019 "
Brad Bishop1d525fa2016-08-17 20:27:37 -040020
21START_TMPL = "op-start-host@.service"
Lei YUd595e592018-05-25 11:41:46 +080022START_TGTFMT = "obmc-host-startmin@{1}.target"
23START_INSTFMT = "op-start-host@{0}.service"
Andrew Geissler3c35a8c2017-02-08 15:54:25 -060024START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
Brad Bishop1d525fa2016-08-17 20:27:37 -040025
Patrick Williamse83c2202021-09-01 16:17:33 -050026SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"