blob: ad9ccd02c6d7f2e60ab82043dfc9bbecfd7aeb4a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "kexecboot linux-as-bootloader"
2DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
3HOMEPAGE = "http://kexecboot.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.6+git${SRCPV}"
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/kexecboot/kexecboot.git"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06009SRC_URI_append_libc-klibc = "\
10 file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch \
11 file://0001-make-Add-compiler-includes-in-cflags.patch \
12"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014inherit autotools
15
16EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
17
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050018CFLAGS += "-fcommon"
19
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020do_install () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022 install -d ${D}/proc
23 install -d ${D}/mnt
24 install -d ${D}/dev
25 install -d ${D}/sys
26}
27
28PACKAGE_ARCH = "${MACHINE_ARCH}"
29
30FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
31
32pkg_postinst_${PN} () {
33 ln -sf ${bindir}/kexecboot $D/init
34}
35
36BBCLASSEXTEND = "klibc"