blob: 2205b72fff6777294c575968fcbb417cf2ac0bdc [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Wireless daemon for Linux"
2HOMEPAGE = "https://iwd.wiki.kernel.org/"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
5
6DEPENDS = "ell"
7
Andrew Geisslerac970dd2021-02-12 15:32:45 -06008SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
9 file://0001-crypto-Update-l_pkcs5_pbkdf2-call-after-rename.patch \
10 "
11SRCREV = "355c2df97e1adfdaee4a67c1705bd76202384687"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012S = "${WORKDIR}/git"
13
14inherit autotools manpages pkgconfig python3native systemd
15
16PACKAGECONFIG ??= " \
17 client \
18 monitor \
19 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
20"
21PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
22PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
23PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
24PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
25PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
26PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
27
28EXTRA_OECONF = "--enable-external-ell"
29
30SYSTEMD_SERVICE_${PN} = " \
31 iwd.service \
32 ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
33"
34
35do_configure_prepend() {
36 install -d ${S}/build-aux
37}
38
39do_install_append() {
40 # If client and monitor are disabled, bindir is empty, causing a QA error
41 rmdir --ignore-fail-on-non-empty ${D}/${bindir}
42}
43
44FILES_${PN} += " \
45 ${datadir}/dbus-1 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050046 ${nonarch_libdir}/modules-load.d \
Andrew Geissler82c905d2020-04-13 13:39:40 -050047 ${systemd_unitdir}/network \
48"
49
50RDEPENDS_${PN} = "dbus"
51
52RRECOMMENDS_${PN} = "\
53 kernel-module-pkcs7-message \
54 kernel-module-pkcs8-key-parser \
55 kernel-module-x509-key-parser \
56"