blob: e6b6476e298a0ca6c38e28c8b0d34300e83f638b [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001SUMMARY = "C library and tools for interacting with the linux GPIO character device"
2AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003
Andrew Geisslera2681d92020-10-16 10:17:07 -05004LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geisslerac970dd2021-02-12 15:32:45 -06007SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \
8 file://run-ptest \
9"
10
Andrew Geissler8fc454f2020-12-11 16:27:59 -060011SRC_URI[md5sum] = "4765470becb619fead3cdaeac61b9a77"
12SRC_URI[sha256sum] = "c601e71846f5ab140c83bc757fdd62a4fda24a9cee39cc5e99c96ec2bf1b06a9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014inherit autotools pkgconfig python3native ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
Andrew Geissler8fc454f2020-12-11 16:27:59 -060016PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev glib-2.0 catch2"
Andrew Geisslera2681d92020-10-16 10:17:07 -050017PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
19
Andrew Geisslera2681d92020-10-16 10:17:07 -050020# Enable cxx bindings by default.
21PACKAGECONFIG ?= "cxx"
22
23# Always build tools - they don't have any additional
24# requirements over the library.
25EXTRA_OECONF = "--enable-tools"
26
27DEPENDS += "autoconf-archive-native"
28
29PACKAGES =+ "${PN}-tools libgpiodcxx"
30FILES_${PN}-tools = "${bindir}/*"
31FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032
33PACKAGES =+ "${PN}-python"
34FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
35RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
36RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060037
38PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'tests', '', d)}"
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/tests
42 cp ${B}/tests/.libs/gpiod-test ${D}${PTEST_PATH}/tests/
43}