blob: 0b8ccbd2171fdb2ac23f5e12b518b916b19474b0 [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
Brad Bishop996bc452019-12-02 13:05:15 -050010SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
11 file://CVE-2019-17498.patch \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060012 file://0001-configure-Conditionally-undefine-backend-m4-macro.patch \
Andrew Geisslera2681d92020-10-16 10:17:07 -050013 file://run-ptest \
Brad Bishop996bc452019-12-02 13:05:15 -050014"
Andrew Geissler72956ed2021-01-08 16:11:14 -060015
16SRC_URI_append_ptest = " file://0001-Don-t-let-host-enviroment-to-decide-if-a-test-is-bui.patch"
17
Brad Bishop2f973922019-11-11 07:58:48 -050018SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
19SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
20
Andrew Geisslera2681d92020-10-16 10:17:07 -050021inherit autotools pkgconfig ptest
Brad Bishop2f973922019-11-11 07:58:48 -050022
23EXTRA_OECONF += "\
24 --with-libz \
25 --with-libz-prefix=${STAGING_LIBDIR} \
26 "
27
28# only one of openssl and gcrypt could be set
29PACKAGECONFIG ??= "openssl"
30PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
31PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
32
Brad Bishope42b3e32020-01-15 22:08:42 -050033BBCLASSEXTEND = "native nativesdk"
Andrew Geisslera2681d92020-10-16 10:17:07 -050034
Andrew Geissler4b7c1152020-11-30 19:55:29 -060035# required for ptest on documentation
Andrew Geissler72956ed2021-01-08 16:11:14 -060036RDEPENDS_${PN}-ptest = "man-db openssh"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060037RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
Andrew Geisslera2681d92020-10-16 10:17:07 -050038
39do_compile_ptest() {
40 sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
41 oe_runmake check
42}
43
44do_install_ptest() {
45 install -d ${D}${PTEST_PATH}/tests
Andrew Geisslera2681d92020-10-16 10:17:07 -050046 install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
Andrew Geissler72956ed2021-01-08 16:11:14 -060047 cp -rf ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests/
48 cp -rf ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
49 cp -rf ${S}/tests/ssh2.sh ${D}${PTEST_PATH}/tests/
50 cp -rf ${S}/tests/etc ${D}${PTEST_PATH}/tests/
Andrew Geissler4b7c1152020-11-30 19:55:29 -060051 mkdir -p ${D}${PTEST_PATH}/docs
52 cp -r ${S}/docs/* ${D}${PTEST_PATH}/docs/
Andrew Geisslera2681d92020-10-16 10:17:07 -050053}