blob: b87a470b4042fb01377c53664076b378b27b3388 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Control process attributes through prctl"
2DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \
3process' behaviour. Usage of the function is fairly messy though, due to \
4limitations in C and linux. This module provides a nice non-messy python(ic) \
5interface."
6SECTION = "devel/python"
7LICENSE = "GPLv3"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=1475481f9ec754d758859bd2c75f6f6f"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10S = "${WORKDIR}/git"
11B = "${S}"
12
Andrew Geisslerac970dd2021-02-12 15:32:45 -060013SRCREV = "5e12e398eb5c4e30d7b29b02458c76d2cc780700"
14PV = "1.8.1+git${SRCPV}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
Andrew Geisslerac970dd2021-02-12 15:32:45 -060016SRC_URI = "git://github.com/seveas/python-prctl;branch=main\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 file://0001-support-cross-complication.patch \
18"
19inherit setuptools3 python3native
20
21DEPENDS += "libcap"
22