Brad Bishop | 870eb53 | 2020-01-06 09:44:45 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A module to control Raspberry Pi GPIO channels" |
| 2 | HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7" |
| 6 | |
| 7 | PYPI_PACKAGE = "RPi.GPIO" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | inherit pypi setuptools3 |
Brad Bishop | 870eb53 | 2020-01-06 09:44:45 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | SRC_URI += "file://0001-Remove-nested-functions.patch \ |
| 12 | file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \ |
| 13 | " |
Brad Bishop | 870eb53 | 2020-01-06 09:44:45 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f" |
| 15 | |
| 16 | COMPATIBLE_MACHINE = "^rpi$" |
Andrew Geissler | 19b4e6c | 2020-09-18 13:33:52 -0500 | [diff] [blame] | 17 | |
| 18 | # ignore issues with -fno-common from gcc-10 until it's fixed in upstream: |
| 19 | # https://sourceforge.net/p/raspberry-gpio-python/tickets/187/ |
| 20 | CFLAGS += "-fcommon" |