blob: f0c8684b0d222d6e8eff616a4279811ed0058d61 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "python bindings for the lz4 compression library by Yann Collet"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
5
6DEPENDS += " \
7 lz4 \
Andrew Geissler5082cc72023-09-11 08:41:39 -04008 python3-setuptools-scm-native \
9 python3-pkgconfig-native \
Andrew Geissler517393d2023-01-13 08:55:19 -060010"
11
12SRC_URI += "file://run-ptest"
13
14SRC_URI[sha256sum] = "e1431d84a9cfb23e6773e72078ce8e65cad6745816d4cbf9ae67da5ea419acda"
15
16inherit pkgconfig pypi python_setuptools_build_meta ptest
17
Andrew Geissler5082cc72023-09-11 08:41:39 -040018RDEPENDS:${PN}-ptest += "\
19 python3-coverage \
20 python3-pytest \
21 python3-pytest-cov \
22 python3-pytest-runner \
23 python3-multiprocessing \
24 python3-psutil \
Andrew Geissler20137392023-10-12 04:59:14 -060025 python3-unittest-automake-output \
Andrew Geissler5082cc72023-09-11 08:41:39 -040026"
Andrew Geissler517393d2023-01-13 08:55:19 -060027
28do_install_ptest() {
29 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
30 # The stream API is experimental and not enabled yet, so don't ship the test suite
31 rm -rf ${D}${PTEST_PATH}/tests/stream
32}
33
34BBCLASSEXTEND = "native nativesdk"