blob: 91ab762eb6d47e7c9b9768984b40d0fe2b83710c [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b707d50badb798e1d897f2c8f649382d"
6
Patrick Williams169d7bc2024-01-05 11:33:25 -06007SRC_URI[sha256sum] = "6db97656fd3fe3f7e5b077f12fa6adb5feb6e0b567a3e99f47ecf5f7ea0a09e3"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 python3-asyncio \
14 python3-compression \
15 python3-json \
16 python3-logging \
17 python3-netclient \
18 python3-numbers \
19 python3-pickle \
20 python3-profile \
21 python3-threading \
22 python3-typing-extensions \
23"
24
25BBCLASSEXTEND = "native nativesdk"