Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python interface for c-ares" |
| 2 | DESCRIPTION = "\ |
| 3 | pycares is a Python module which provides an interface to c-ares. c-ares is \ |
| 4 | a C library that performs DNS requests and name resolutions asynchronously." |
| 5 | HOMEPAGE = "https://github.com/saghul/pycares" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "c542696f6dac978e9d99192384745a65f80a7d9450501151e4a7563e06010d45" |
| 10 | |
| 11 | PYPI_PACKAGE = "pycares" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | DEPENDS += "${PYTHON_PN}-cffi-native" |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | ${PYTHON_PN}-cffi \ |
| 19 | ${PYTHON_PN}-idna \ |
| 20 | " |