Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Common code for generating core reference images |
| 2 | # |
| 3 | # Copyright (C) 2007-2011 Linux Foundation |
| 4 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 5 | # IMAGE_FEATURES control content of the core reference images |
| 6 | # |
| 7 | # By default we install packagegroup-core-boot and packagegroup-base-extended packages; |
| 8 | # this gives us working (console only) rootfs. |
| 9 | # |
| 10 | # Available IMAGE_FEATURES: |
| 11 | # |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 12 | # - weston - Weston Wayland compositor |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | # - x11 - X server |
| 14 | # - x11-base - X server with minimal environment |
| 15 | # - x11-sato - OpenedHand Sato environment |
| 16 | # - tools-debug - debugging tools |
| 17 | # - eclipse-debug - Eclipse remote debugging support |
| 18 | # - tools-profile - profiling tools |
| 19 | # - tools-testapps - tools usable to make some device tests |
| 20 | # - tools-sdk - SDK (C/C++ compiler, autotools, etc.) |
| 21 | # - nfs-server - NFS server |
| 22 | # - nfs-client - NFS client |
| 23 | # - ssh-server-dropbear - SSH server (dropbear) |
| 24 | # - ssh-server-openssh - SSH server (openssh) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | # - hwcodecs - Install hardware acceleration codecs |
| 26 | # - package-management - installs package management tools and preserves the package manager database |
| 27 | # - debug-tweaks - makes an image suitable for development, e.g. allowing passwordless root logins |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | # - empty-root-password |
| 29 | # - allow-empty-password |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | # - allow-root-login |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | # - post-install-logging |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | # - dev-pkgs - development packages (headers, etc.) for all installed packages in the rootfs |
| 33 | # - dbg-pkgs - debug symbol packages for all installed packages in the rootfs |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame] | 34 | # - lic-pkgs - license packages for all installed pacakges in the rootfs, requires |
| 35 | # LICENSE_CREATE_PACKAGE="1" to be set when building packages too |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 36 | # - doc-pkgs - documentation packages for all installed packages in the rootfs |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 37 | # - bash-completion-pkgs - bash-completion packages for recipes using bash-completion bbclass |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 38 | # - ptest-pkgs - ptest packages for all ptest-enabled recipes |
| 39 | # - read-only-rootfs - tweaks an image to support read-only rootfs |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | # - stateless-rootfs - systemctl-native not run, image populated by systemd at runtime |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 41 | # - splash - bootup splash screen |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 42 | # |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 43 | FEATURE_PACKAGES_weston = "packagegroup-core-weston" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 44 | FEATURE_PACKAGES_x11 = "packagegroup-core-x11" |
| 45 | FEATURE_PACKAGES_x11-base = "packagegroup-core-x11-base" |
| 46 | FEATURE_PACKAGES_x11-sato = "packagegroup-core-x11-sato" |
| 47 | FEATURE_PACKAGES_tools-debug = "packagegroup-core-tools-debug" |
| 48 | FEATURE_PACKAGES_eclipse-debug = "packagegroup-core-eclipse-debug" |
| 49 | FEATURE_PACKAGES_tools-profile = "packagegroup-core-tools-profile" |
| 50 | FEATURE_PACKAGES_tools-testapps = "packagegroup-core-tools-testapps" |
| 51 | FEATURE_PACKAGES_tools-sdk = "packagegroup-core-sdk packagegroup-core-standalone-sdk-target" |
| 52 | FEATURE_PACKAGES_nfs-server = "packagegroup-core-nfs-server" |
| 53 | FEATURE_PACKAGES_nfs-client = "packagegroup-core-nfs-client" |
| 54 | FEATURE_PACKAGES_ssh-server-dropbear = "packagegroup-core-ssh-dropbear" |
| 55 | FEATURE_PACKAGES_ssh-server-openssh = "packagegroup-core-ssh-openssh" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 56 | FEATURE_PACKAGES_hwcodecs = "${MACHINE_HWCODECS}" |
| 57 | |
| 58 | |
| 59 | # IMAGE_FEATURES_REPLACES_foo = 'bar1 bar2' |
| 60 | # Including image feature foo would replace the image features bar1 and bar2 |
| 61 | IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear" |
| 62 | |
| 63 | # IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2' |
| 64 | # An error exception would be raised if both image features foo and bar1(or bar2) are included |
| 65 | |
| 66 | MACHINE_HWCODECS ??= "" |
| 67 | |
| 68 | CORE_IMAGE_BASE_INSTALL = '\ |
| 69 | packagegroup-core-boot \ |
| 70 | packagegroup-base-extended \ |
| 71 | \ |
| 72 | ${CORE_IMAGE_EXTRA_INSTALL} \ |
| 73 | ' |
| 74 | |
| 75 | CORE_IMAGE_EXTRA_INSTALL ?= "" |
| 76 | |
| 77 | IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}" |
| 78 | |
| 79 | inherit image |