Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Host API C++ bindings" |
| 2 | DESCRIPTION = "OpenCL compute API headers C++ bindings from Khronos Group" |
| 3 | LICENSE = "Khronos" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e4a01f0c56b39419aa287361a82df00" |
| 5 | SECTION = "base" |
| 6 | |
| 7 | SRC_URI = "git://github.com/KhronosGroup/OpenCL-CLHPP.git;protocol=https" |
| 8 | |
| 9 | PV = "2.0.10+git${SRCPV}" |
| 10 | SRCREV = "acd6972bc65845aa28bd9f670dec84cbf8b760f3" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | do_configure () { |
| 15 | : |
| 16 | } |
| 17 | |
| 18 | # Only cl2.hpp is necessary. |
| 19 | # Base on the repo, Directly input_cl2.hpp copied as cl2.hpp |
| 20 | do_compile () { |
| 21 | : |
| 22 | } |
| 23 | |
| 24 | do_install () { |
| 25 | install -d ${D}${includedir}/CL/ |
| 26 | install -m 0644 ${S}/input_cl2.hpp ${D}${includedir}/CL/cl2.hpp |
| 27 | } |
| 28 | |
| 29 | ALLOW_EMPTY_${PN} = "1" |