blob: 309f625a40fa60a87c98bdf32e8932e35a7eb045 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# avoids build breaks when using no-static-libs.inc
2DISABLE_STATIC = ""
3
Brad Bishop19323692019-04-05 15:28:33 -04004B = "${WORKDIR}/build"
5
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006EXTRA_OECONF_append = " ${PACKAGECONFIG_CONFARGS}"
7
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -05008EXTRA_OEWAF_BUILD ??= ""
9# In most cases, you want to pass the same arguments to `waf build` and `waf
10# install`, but you can override it if necessary
11EXTRA_OEWAF_INSTALL ??= "${EXTRA_OEWAF_BUILD}"
12
Brad Bishopc342db32019-05-15 21:57:59 -040013def waflock_hash(d):
14 # Calculates the hash used for the waf lock file. This should include
15 # all of the user controllable inputs passed to waf configure. Note
16 # that the full paths for ${B} and ${S} are used; this is OK and desired
17 # because a change to either of these should create a unique lock file
18 # to prevent collisions.
19 import hashlib
20 h = hashlib.sha512()
21 def update(name):
22 val = d.getVar(name)
23 if val is not None:
24 h.update(val.encode('utf-8'))
25 update('S')
26 update('B')
27 update('prefix')
28 update('EXTRA_OECONF')
29 return h.hexdigest()
30
31# Use WAFLOCK to specify a separate lock file. The build is already
32# sufficiently isolated by setting the output directory, this ensures that
33# bitbake won't step on toes of any other configured context in the source
34# directory (e.g. if the source is coming from externalsrc and was previously
35# configured elsewhere).
36export WAFLOCK = ".lock-waf_oe_${@waflock_hash(d)}_build"
37BB_HASHBASE_WHITELIST += "WAFLOCK"
38
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039python waf_preconfigure() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040040 import subprocess
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041 from distutils.version import StrictVersion
Brad Bishop316dfdd2018-06-25 12:45:53 -040042 subsrcdir = d.getVar('S')
43 wafbin = os.path.join(subsrcdir, 'waf')
44 try:
45 result = subprocess.check_output([wafbin, '--version'], cwd=subsrcdir, stderr=subprocess.STDOUT)
46 version = result.decode('utf-8').split()[1]
47 if StrictVersion(version) >= StrictVersion("1.8.7"):
48 d.setVar("WAF_EXTRA_CONF", "--bindir=${bindir} --libdir=${libdir}")
49 except subprocess.CalledProcessError as e:
50 bb.warn("Unable to execute waf --version, exit code %d. Assuming waf version without bindir/libdir support." % e.returncode)
51 except FileNotFoundError:
52 bb.fatal("waf does not exist in %s" % subsrcdir)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050053}
54
55do_configure[prefuncs] += "waf_preconfigure"
56
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057waf_do_configure() {
Brad Bishop19323692019-04-05 15:28:33 -040058 (cd ${S} && ./waf configure -o ${B} --prefix=${prefix} ${WAF_EXTRA_CONF} ${EXTRA_OECONF})
Patrick Williamsc124f4f2015-09-15 14:41:29 -050059}
60
Brad Bishop316dfdd2018-06-25 12:45:53 -040061do_compile[progress] = "outof:^\[\s*(\d+)/\s*(\d+)\]\s+"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062waf_do_compile() {
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -050063 (cd ${S} && ./waf build ${@oe.utils.parallel_make_argument(d, '-j%d', limit=64)} ${EXTRA_OEWAF_BUILD})
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064}
65
66waf_do_install() {
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -050067 (cd ${S} && ./waf install --destdir=${D} ${EXTRA_OEWAF_INSTALL})
Patrick Williamsc124f4f2015-09-15 14:41:29 -050068}
69
70EXPORT_FUNCTIONS do_configure do_compile do_install