blob: b283add12f2297b8cf591cac23ac7858eb710819 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050030SRCREV = "0d79a93e6ca44d9bc95973faea6bcd7b0c6d1f43"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
33 file://0001-build-Add-option-to-select-libc-implementation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050034 file://0004-guard-mallocopt-with-__GLIBC__.patch \
35 file://0007-Fix-test_proc_kill-hanging.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 file://0001-Add-more-musl-exclusions.patch \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050037 file://0001-ptrace01-Fix-missing-format-string.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050038 file://0001-sigwaitinfo-Do-not-run-invalid-undefined-test-cases.patch \
Andrew Geisslerd25ed322020-06-27 00:28:28 -050039 file://0001-syscalls-copy_file_range02-Expect-EFBIG-in-subcase-m.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 "
41
42S = "${WORKDIR}/git"
43
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050044inherit autotools-brokensep pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050045
46TARGET_CC_ARCH += "${LDFLAGS}"
47
48export prefix = "/opt/${PN}"
49export exec_prefix = "/opt/${PN}"
50
51PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
52EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
53EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
54# ltp network/rpc test cases ftbfs when libtirpc is found
55EXTRA_OECONF += " --without-tirpc "
56
57do_install(){
58 install -d ${D}${prefix}/
59 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
60
61 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
62 # as it lacks dependency on some perl moudle such as LWP::Simple
63 # And this script previously works as a tool for analyzing failures from LTP
64 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
65 # http://khack.osdl.org to retrieve ltp test results run on
66 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
67 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
68
69 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
70 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
71
72 # Makefile were configured in the build system
73 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
74 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
75 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
76 -e 's@[^ ]*--sysroot=[^ "]*@@g'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050077
78 # The controllers memcg_stree test seems to cause us hangs and takes 900s
79 # (maybe we expect more regular output?), anyhow, skip it
80 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler82c905d2020-04-13 13:39:40 -050081}
82
83RDEPENDS_${PN} = "\
84 attr \
85 bash \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050086 bc \
87 coreutils \
Andrew Geissler82c905d2020-04-13 13:39:40 -050088 cpio \
89 cronie \
90 curl \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050091 e2fsprogs \
Andrew Geissler82c905d2020-04-13 13:39:40 -050092 e2fsprogs-mke2fs \
93 expect \
94 file \
95 gawk \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050096 gdb \
Andrew Geissler82c905d2020-04-13 13:39:40 -050097 gzip \
98 iproute2 \
99 ldd \
100 libaio \
101 logrotate \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500102 net-tools \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500103 perl \
104 python3-core \
105 procps \
106 quota \
107 unzip \
108 util-linux \
109 which \
110 tar \
111"
112
113FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
114
115# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
116INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
117INSANE_SKIP_${PN} += "already-stripped staticdev"
118
119# Avoid file dependency scans, as LTP checks for things that may or may not
120# exist on the running system. For instance it has specific checks for
121# csh and ksh which are not typically part of OpenEmbedded systems (but
122# can be added via additional layers.)
123SKIP_FILEDEPS_${PN} = '1'