Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Line-oriented text editor" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/ed/" |
| 3 | DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands." |
| 4 | |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 7 | file://ed.h;endline=20;md5=c3212b6c53b09668107420af9368c0ef \ |
| 8 | file://main.c;endline=17;md5=e5d2ae5ddd1ecb87dc71702c06dd06dc \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | " |
| 10 | |
| 11 | SECTION = "base" |
| 12 | |
| 13 | CVE_PRODUCT = "gnu:ed" |
| 14 | |
| 15 | # LSB states that ed should be in /bin/ |
| 16 | bindir = "${base_bindir}" |
| 17 | |
| 18 | # Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/ |
| 19 | SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz" |
| 20 | UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/" |
| 21 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 22 | SRC_URI[sha256sum] = "b1a463b297a141f9876c4b1fcd01477f645cded92168090e9a35db2af4babbca" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 23 | |
| 24 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 25 | |
| 26 | inherit texinfo |
| 27 | |
| 28 | do_configure() { |
| 29 | ${S}/configure |
| 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | oe_runmake 'DESTDIR=${D}' install |
| 34 | # Info dir listing isn't interesting at this point so remove it if it exists. |
| 35 | if [ -e "${D}${infodir}/dir" ]; then |
| 36 | rm -f ${D}${infodir}/dir |
| 37 | fi |
| 38 | } |