blob: 4306ff99c2aef3380f5845d81770252790bbdaa1 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
Patrick Venture191bfab2018-10-17 07:42:11 -07007PV = "1.0+git${SRCPV}"
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05008LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Lei YU3ba97552019-03-11 17:32:32 +080011inherit autotools pkgconfig systemd
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050012inherit obmc-phosphor-dbus-service
13
Adriana Kobylakb0e85222020-07-15 21:42:04 -050014# Static configuration. This is the default if no other layout is specified.
15inherit ${@bb.utils.contains_any('DISTRO_FEATURES', \
16 'openpower-ubi-fs phosphor-mmc', \
17 '', \
18 'openpower-software-manager-static', d)}
19
20# UBI layout
Lei YU3ba97552019-03-11 17:32:32 +080021inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', \
22 'openpower-software-manager-ubi', \
Adriana Kobylakb0e85222020-07-15 21:42:04 -050023 '', d)}
24# eMMC layout
25inherit ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', \
26 'openpower-software-manager-mmc', \
27 '', d)}
28
29# Virtual PNOR
Adriana Kobylak8b805bd2019-10-25 15:24:38 -050030inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-virtual-pnor', \
31 'openpower-software-manager-virtual-pnor', \
32 '', d)}
Lei YU3ba97552019-03-11 17:32:32 +080033
Adriana Kobylakd7c95052018-05-07 13:28:09 -050034PACKAGECONFIG[verify_pnor_signature] = "--enable-verify_pnor_signature,--disable-verify_pnor_signature"
Lei YU3ba97552019-03-11 17:32:32 +080035PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout,--disable-ubifs_layout,,mtd-utils-ubifs"
Adriana Kobylakb0e85222020-07-15 21:42:04 -050036PACKAGECONFIG[mmc_layout] = "--enable-mmc_layout,--disable-mmc_layout"
Adriana Kobylak8b805bd2019-10-25 15:24:38 -050037PACKAGECONFIG[virtual_pnor] = "--enable-virtual_pnor,--disable-virtual_pnor"
Adriana Kobylakd7c95052018-05-07 13:28:09 -050038
Adriana Kobylak4315c912018-10-10 14:29:15 -050039EXTRA_OECONF += " \
40 PNOR_MSL="v2.0.10 v2.2" \
41 "
42
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050043DEPENDS += " \
44 autoconf-archive-native \
Patrick Williams5ec7af72020-02-24 21:48:12 -060045 openssl \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050046 phosphor-dbus-interfaces \
47 phosphor-logging \
48 sdbusplus \
49 "
50
51RDEPENDS_${PN} += " \
Patrick Williams21d65692017-08-09 17:36:04 -050052 virtual-obmc-image-manager \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050053 "
54
Adriana Kobylak2e950822017-06-02 09:22:40 -050055S = "${WORKDIR}/git"
56
57SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
58
Andrew Geisslerc7edaeb2020-07-16 21:41:04 +000059SRCREV = "0e0a3b1ae3e96661030c872a17c8fc5fa849e929"
Adriana Kobylak2e950822017-06-02 09:22:40 -050060
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050061DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
Adriana Kobylak2e950822017-06-02 09:22:40 -050062
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050063SYSTEMD_SERVICE_${PN} += " \
Adriana Kobylak32803f82018-10-10 09:47:17 -050064 op-pnor-msl.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050065 "