blob: 3523bad3e29d6b8316bcaa8cf5ef0b47032ee206 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "System-wide Performance Profiler for Linux"
2HOMEPAGE = "http://www.sysprof.com"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-3.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007inherit gnomebase gnome-help gettext systemd upstream-version-is-even gsettings mime mime-xdg
8
9DEPENDS += " \
10 glib-2.0-native \
11 yelp-tools-native \
12 libxml2-native \
13 glib-2.0 \
14 json-glib \
15"
16
Patrick Williams03907ee2022-05-01 06:28:52 -050017SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch"
18SRC_URI[archive.sha256sum] = "ab5d9f5b71973b3088d58a1bfdf1dc23c39a02f5fce4e5e9c73e034b178b005b"
Andrew Geissler595f6302022-01-24 19:11:47 +000019
Patrick Williams03907ee2022-05-01 06:28:52 -050020PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd libsysprof', '', d)} \
21 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \
22 libunwind"
23# nongnu libunwind needs porting to RV32
24PACKAGECONFIG:remove:riscv32 = "libunwind"
25
Andrew Geissler595f6302022-01-24 19:11:47 +000026PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle"
27PACKAGECONFIG[sysprofd] = "-Dwith_sysprofd=bundled,-Dwith_sysprofd=none,polkit"
28PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit"
Patrick Williams03907ee2022-05-01 06:28:52 -050029PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
Andrew Geissler595f6302022-01-24 19:11:47 +000030
31EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system"
32
33SOLIBS = ".so"
34FILES_SOLIBSDEV = ""
35
36SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof2.service sysprof3.service', '', d)}"
37
38FILES:${PN} += " \
39 ${datadir}/dbus-1/system-services \
40 ${datadir}/dbus-1/system.d \
41 ${datadir}/dbus-1/interfaces \
42 ${datadir}/metainfo \
43"