blob: 143796eb329158af991267b01891b4717e1f9f92 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Brad Bishope1615142020-04-22 14:06:02 -04002
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003PACKAGECONFIG:append:p10bmc = " host-dump-transport-pldm"
4PACKAGECONFIG:append:witherspoon-tacoma = " host-dump-transport-pldm"
Matt Spinlerb9e821a2018-03-29 16:34:38 -05005
Adriana Kobylakb96c7502021-08-06 16:25:30 +00006PACKAGECONFIG:append:p10bmc = " openpower-dumps-extension"
7PACKAGECONFIG:append:witherspoon-tacoma = " openpower-dumps-extension"
Dhruvaraj Subhashchandran21ebf782020-09-24 01:33:00 -05008
Dhruvaraj Subhashchandran26fb25b2022-01-18 07:07:18 -06009SYSTEMD_SERVICE:${PN}-manager:p10bmc += "clear_hostdumps_poweroff.service"
10
Matt Spinlerb9e821a2018-03-29 16:34:38 -050011install_ibm_plugins() {
Marri Devender Raoce928ac2022-04-08 08:54:38 -050012 install ${S}/tools/dreport.d/ibm.d/plugins.d/* ${D}${dreport_plugin_dir}/
Matt Spinlerb9e821a2018-03-29 16:34:38 -050013}
14
15#Link in the plugins so dreport run them at the appropriate time
16python link_ibm_plugins() {
Marri Devender Raoce928ac2022-04-08 08:54:38 -050017 source = d.getVar('S', True)
18 source_path = os.path.join(source, "tools", "dreport.d", "ibm.d", "plugins.d")
19 op_plugins = os.listdir(source_path)
20 for op_plugin in op_plugins:
21 op_plugin_name = os.path.join(source_path, op_plugin)
22 install_dreport_user_script(op_plugin_name, d)
Matt Spinlerb9e821a2018-03-29 16:34:38 -050023}
24
Chirag Sharma4b5211d2020-09-29 08:18:17 -050025#Install dump header script from dreport/ibm.d to dreport/include.d
26install_dreport_header() {
27 install -d ${D}${dreport_include_dir}
PriyangaRamasamybcbcea82021-03-02 22:49:05 -060028 install -m 0755 ${S}/tools/dreport.d/ibm.d/gendumpheader ${D}${dreport_include_dir}/
Chirag Sharma4b5211d2020-09-29 08:18:17 -050029}
30
31IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
Marri Devender Raoce928ac2022-04-08 08:54:38 -050032IBM_INSTALL_POSTFUNCS:p10bmc += "install_dreport_header"
Chirag Sharma4b5211d2020-09-29 08:18:17 -050033
34do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"