blob: c94e49dab3a146334bfc4c120c05fe4c252a2ce4 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The extensible, standards compliant build backend used by Hatch"
2HOMEPAGE = "https://hatch.pypa.io/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
5
6inherit pypi python_hatchling
7
Andrew Geissler3eeda902023-05-19 10:14:02 -05008DEPENDS += "python3-pluggy-native python3-pathspec-native python3-packaging-native python3-editables-native python3-trove-classifiers-native"
Andrew Geissler517393d2023-01-13 08:55:19 -06009DEPENDS:remove:class-native = "python3-hatchling-native"
10
Andrew Geissler8f840682023-07-21 09:09:43 -050011SRC_URI[sha256sum] = "50e99c3110ce0afc3f7bdbadff1c71c17758e476731c27607940cfa6686489ca"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13do_compile:prepend() {
14 export PYTHONPATH=src
15}
16
17BBCLASSEXTEND = "native nativesdk"