Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "An IPC library for high performance servers" |
| 2 | DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \ |
| 3 | It provides high performance logging, tracing, ipc, and poll." |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "LGPL-2.1-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | |
| 12 | SRCREV = "758044bed5f615c90818aa5431d00303288888e5" |
| 13 | SRC_URI = "git://github.com/ClusterLabs/${BPN}.git;branch=main;protocol=https \ |
| 14 | " |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS += "libxml2" |
| 18 | |
| 19 | CFLAGS += "-pthread -D_REENTRANT" |
| 20 | |
| 21 | do_configure:prepend() { |
| 22 | ( cd ${S} |
| 23 | ${S}/autogen.sh ) |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native" |