blob: f477f99bafd5ce0c64b2c4890e138a23ea70b421 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "http://expat.sourceforge.net/"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=5b8620d98e49772d95fc1d291c26aa79"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://libtool-tag.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050011 file://run-ptest \
12 file://0001-Add-output-of-tests-result.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013 "
14
Brad Bishopf3f93bb2019-10-16 14:33:32 -040015SRC_URI[md5sum] = "875a2c2ff3e8eb9e5a5cd62db2033ab5"
16SRC_URI[sha256sum] = "f1063084dc4302a427dabcca499c8312b3a32a29b7d2506653ecc8f950a9a237"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
Andrew Geisslerb7d28612020-07-24 16:15:54 -050018EXTRA_OECMAKE_class-native += "-DEXPAT_BUILD_DOCS=OFF"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Andrew Geisslerb7d28612020-07-24 16:15:54 -050020RDEPENDS_${PN}-ptest += "bash"
21
22inherit cmake lib_package ptest
23
24do_install_ptest_class-target() {
25 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026}
27
Andrew Geisslerb7d28612020-07-24 16:15:54 -050028BBCLASSEXTEND += "native nativesdk"