blob: c9945d45ebd901000eb867d7bce4e8e6006f2b7d [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004SUMMARY = "BSD compatible headers"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05005LICENSE = "BSD-3-Clause & BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://sys-queue.h;beginline=1;endline=32;md5=c6352b0f03bb448600456547d334b56f"
7SECTION = "devel"
8
9SRC_URI = "file://sys-queue.h \
10 file://sys-tree.h \
11 file://sys-cdefs.h \
12 "
13do_configure[noexec] = "1"
14do_compile[noexec] = "1"
15
16INHIBIT_DEFAULT_DEPS = "1"
17
18S = "${WORKDIR}"
19
20do_install() {
21 install -Dm 0644 ${S}/sys-queue.h ${D}${includedir}/sys/queue.h
22 install -Dm 0644 ${S}/sys-tree.h ${D}${includedir}/sys/tree.h
23 install -Dm 0644 ${S}/sys-cdefs.h ${D}${includedir}/sys/cdefs.h
24}
25#
26# We will skip parsing for non-musl systems
27#
28
29COMPATIBLE_HOST = ".*-musl.*"
30RDEPENDS_${PN}-dev = ""
31RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"