blob: 3d5757286554c8ba6a55957f588a0a773f1b80fb [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD-2-Clause"
7
8DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
9BBCLASSEXTEND = "native nativesdk"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
12
13SRC_URI = "https://github.com/westes/flex/releases/download/v${PV}/flex-${PV}.tar.gz \
14 file://run-ptest \
15 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
16 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
17 file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050018 file://check-funcs.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050019 "
20
21SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
22SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
23
24# Flex has moved to github from 2.6.1 onwards
25UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
26UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
27
28inherit autotools gettext texinfo ptest
29
30M4 = "${bindir}/m4"
31M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
32EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
33EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
34
35EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
36
37do_install_append_class-native() {
38 create_wrapper ${D}/${bindir}/flex M4=${M4}
39}
40
41do_install_append_class-nativesdk() {
42 create_wrapper ${D}/${bindir}/flex M4=${M4}
43}
44
45PACKAGES =+ "${PN}-libfl"
46
47FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
48
49RDEPENDS_${PN} += "m4"
50RDEPENDS_${PN}-ptest += "bash gawk make"
51
52do_compile_ptest() {
53 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
54}
55
56do_install_ptest() {
57 mkdir -p ${D}${PTEST_PATH}/build-aux/
58 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
59 cp -r ${S}/tests/* ${D}${PTEST_PATH}
60 cp -r ${B}/tests/* ${D}${PTEST_PATH}
61 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
62 -e 's|${DEBUG_PREFIX_MAP}||g' \
63 -e 's:${HOSTTOOLS_DIR}/::g' \
64 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
65 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
66 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
67 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
68 -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
69 -i ${D}${PTEST_PATH}/Makefile
70}
71# The uninative loader is different on i386 & x86_64 hosts. Since it is only
72# being replaced with /bin/false anyway, it doesn't need to be part of the task
73# hash
74do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
75
76# Not Apache Flex, or Adobe Flex, or IBM Flex.
77CVE_PRODUCT = "flex_project:flex"