blob: 29e87081d3f4a7066297ddba3b8d3df7d07b51b9 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
Andrew Geissler82c905d2020-04-13 13:39:40 -05009SRC_URI = "https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
10 file://Makefile-missing-test-dir.patch \
11 file://run-ptest \
12 file://0001-test-regress_dns.c-patch-out-tests-that-require-a-wo.patch \
13 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014
Andrew Geisslerb7d28612020-07-24 16:15:54 -050015SRC_URI[sha256sum] = "92e6de1be9ec176428fd2367677e61ceffc2ee1cb119035037a27d346b0403bb"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
17UPSTREAM_CHECK_URI = "http://libevent.org/"
18
19S = "${WORKDIR}/${BPN}-${PV}-stable"
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
23
24inherit autotools
25
26# Needed for Debian packaging
27LEAD_SONAME = "libevent-2.1.so"
28
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029inherit ptest multilib_header
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030
31DEPENDS = "zlib"
32
Brad Bishop1d80a2e2019-11-15 16:35:03 -050033PACKAGES_DYNAMIC = "^${PN}-.*$"
34python split_libevent_libs () {
35 do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True)
36}
37PACKAGESPLITFUNCS_prepend = "split_libevent_libs "
38
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039BBCLASSEXTEND = "native nativesdk"
40
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041do_install_append() {
Brad Bishop1d80a2e2019-11-15 16:35:03 -050042 rm ${D}${bindir}/event_rpcgen.py
43 rmdir ${D}${bindir}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044 oe_multilib_header event2/event-config.h
45}
46
Brad Bishopd7bf8c12018-02-25 22:55:05 -050047do_install_ptest() {
48 install -d ${D}${PTEST_PATH}/test
49 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
50 do
51 install -m 0755 $file ${D}${PTEST_PATH}/test
52 done
Brad Bishop79641f22019-09-10 07:20:22 -040053
54 # handle multilib
55 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056}