blob: f5ef42a31ddc7f0cd971ba7746f89403b05cb1d0 [file] [log] [blame]
Matt Spinler85b484c2019-05-03 14:34:40 -05001SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
Brad Bishop3a3250e2019-05-22 19:11:38 -04002PR = "r1"
3LICENSE = "Apache-2.0"
Brad Bishopd77088a2019-09-13 13:06:15 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Brad Bishop3a3250e2019-05-22 19:11:38 -04005
6inherit allarch
7inherit phosphor-inventory-manager
8
9S = "${WORKDIR}"
10
Andrew Geissler15ea0472022-07-18 12:25:07 -040011SRC_URI:append:ibm-ac-server = " file://inventory-cleanup.yaml"
Brad Bishop3a3250e2019-05-22 19:11:38 -040012
Andrew Geissler15ea0472022-07-18 12:25:07 -040013do_install:append:ibm-ac-server() {
Brad Bishop3a3250e2019-05-22 19:11:38 -040014 install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
15}
16
Andrew Geissler15ea0472022-07-18 12:25:07 -040017FILES:${PN}:append:ibm-ac-server = " ${base_datadir}/events.d/inventory-cleanup.yaml"