blob: 63cbf21e516d0ad33f4f1e5e8fec05f2d355fc16 [file] [log] [blame]
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
4PR = "r1"
Patrick Venture4f792732018-10-02 20:51:15 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venture4f792732018-10-02 20:51:15 -07008
Nan Zhou175f5022022-08-29 17:43:49 +00009inherit meson pkgconfig
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053010inherit obmc-phosphor-dbus-service
11
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053012DEPENDS += "sdbusplus"
13DEPENDS += "phosphor-logging"
14DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph926556d2018-07-10 12:23:06 -050015DEPENDS += "boost"
Andrew Geissler1de95de2018-10-09 04:10:28 +000016DEPENDS += "nss-pam-ldapd"
Brad Bishop44f3cce2019-03-22 23:41:42 -040017DEPENDS += "systemd"
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050018PACKAGE_BEFORE_PN = "phosphor-ldap"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053019
Nan Zhou175f5022022-08-29 17:43:49 +000020EXTRA_OEMESON = "-Dtests=disabled"
21
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070022inherit useradd
23
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050024USERADD_PACKAGES = "${PN} phosphor-ldap"
25DBUS_PACKAGES = "${USERADD_PACKAGES}"
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070026# add groups needed for privilege maintenance
Patrick Williams12fc9392021-08-06 09:16:53 -050027GROUPADD_PARAM:${PN} = "priv-admin; priv-operator; priv-user "
28GROUPADD_PARAM:phosphor-ldap = "priv-admin; priv-operator; priv-user "
Richard Marian Thomaiyar7a8e9b22018-12-14 09:04:40 +053029
Patrick Williams12fc9392021-08-06 09:16:53 -050030DBUS_SERVICE:${PN} += "xyz.openbmc_project.User.Manager.service"
31FILES:phosphor-ldap += " \
Patrick Ventured8014ce2019-04-04 10:03:09 -070032 ${bindir}/phosphor-ldap-conf \
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050033"
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020034FILES:${PN} += " \
Anton Blanchard397b2b12022-08-02 23:37:41 -060035 ${systemd_unitdir} \
Andrew Geissler30cd3822021-10-15 01:41:20 +000036 ${datadir}/dbus-1 \
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020037 ${datadir}/phosphor-certificate-manager \
38"
Patrick Williams12fc9392021-08-06 09:16:53 -050039DBUS_SERVICE:phosphor-ldap = " \
Tom Joseph42276262018-10-07 05:51:04 -050040 xyz.openbmc_project.Ldap.Config.service \
Tom Joseph42276262018-10-07 05:51:04 -050041"
Patrick Williamsbb99d222022-01-24 15:55:09 -060042SRC_URI += "git://github.com/openbmc/phosphor-user-manager;branch=master;protocol=https"
Andrew Geisslere9b60fc2022-09-13 13:11:10 -050043SRCREV = "0076afe155adbf9f1774fafe5e190926224a650e"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053044S = "${WORKDIR}/git"